Slow / no access to www.emich.edu
Incident Report for Eastern Michigan University I.T.
Resolved
Cloudflare indicates the issue has been resolved.
Posted Jul 17, 2020 - 18:59 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 17, 2020 - 18:58 EDT
Monitoring
Cloudflare has implemented a fix and are monitoring results.
Posted Jul 17, 2020 - 18:36 EDT
Update
We are continuing to investigate this issue.
Posted Jul 17, 2020 - 17:38 EDT
Investigating
The issues appears to be occurring with the CloudFlare service. I.T. have reported the problem to CloudFlare.
Posted Jul 17, 2020 - 17:38 EDT
This incident affected: Communication & Collaboration Services (www.emich.edu).