ITService / Samanage is Unavilable.
Incident Report for Eastern Michigan University I.T.
Resolved
IT Service is once again back online.
Posted Mar 08, 2023 - 09:01 EST
Investigating
We are currently investigating this issue.
Posted Mar 08, 2023 - 07:48 EST
This incident affected: I.T. Service Desk System.