Campus Internet Connection Down

Incident Report for Eastern Michigan University I.T.

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 20:03 EDT

Monitoring

Merit reports service has been restored. We will continue to monitor.
Posted Jun 16, 2026 - 15:14 EDT

Update

Merit reports that they expect to complete the fiber optic cable repairs around 3:00PM with service restoration by or before 3:15.
Posted Jun 16, 2026 - 14:46 EDT

Identified

Merit has identified the issue. They are working to repair a fiber break and also working to re-route EMU traffic around that break. No ETA on repairs as yet.
Posted Jun 16, 2026 - 13:58 EDT

Investigating

The campus Internet connection appears to be down. We are investigating the issue.
Posted Jun 16, 2026 - 13:36 EDT
This incident affected: Network Services (Campus Internet Link).