Microsoft has initiated the deployment of their ‘last known good’ configuration, which has now successfully been completed. Customers may have begun to see initial signs of recovery. At this stage, they anticipate full mitigation within the next four hours as they continue to recover nodes. This means we expect recovery to happen by 23:20 UTC on 29 October 2025.
Posted Oct 29, 2025 - 15:28 EDT
Update
Microsoft has initiated the deployment of our last known good configuration, which is expected to complete within 30 minutes. As this deployment progresses, customers should begin to see initial signs of recovery. Once completed, we will begin recovering nodes and routing traffic through these healthy nodes.
Posted Oct 29, 2025 - 14:36 EDT
Investigating
Microsoft began experiencing issues within their Azure infrastructure at approximately 16:00 UTC on 29 October 2025. This has led to degraded performance for SSO authentication to services such as Zoom, my.emich and Canvas. Already established authentication sessions do not appear to be impacted.
Posted Oct 29, 2025 - 13:28 EDT
This incident affected: Authentication, Accounts and Passwords (Microsoft EntraID SSO Services).