Cloudflare Global Network experiencing issues

Incident Report for Eastern Michigan University I.T.

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 11:52 EST

Monitoring

Cloudflare has implemented a fix. We believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 10:12 EST

Identified

Cloudflare is experiencing service issues with their global network, creating service issues for several sites such as www.emich.edu and my.emich.edu. Many services that people may access through those websites are still available and may be reached directly:

GMail: https://mail.emich.edu
Canvas: https://canvas.emich.edu
Banner: https://bannerwebadmin.oci.emich.edu/applicationNavigator/seamless

Self Service Banner links:
Student profile: https://bannerweb.oci.emich.edu/StudentSelfService/ssb/studentProfile
Financial Aid: https://bannerweb.oci.emich.edu/StudentSelfService/ssb/financialAid#!/dashboard/home
Registration: https://bannerweb.oci.emich.edu/StudentRegistrationSsb
Employee Dashboard: https://bannerweb.oci.emich.edu/EmployeeSelfService/ssb/hrDashboard

From https://www.cloudflarestatus.com/:

Update - We have made changes that have allowed Cloudflare Access and WARP to recover. Error levels for Access and WARP users have returned to pre-incident rates.
We have re-enabled WARP access in London.

We are continuing to work towards restoring other services.
Nov 18, 2025 - 13:13 UTC
Posted Nov 18, 2025 - 08:32 EST
This incident affected: my.emich.edu and Communication & Collaboration Services (www.emich.edu).