Canvas is unavailable
Incident Report for Eastern Michigan University I.T.
Resolved
Instructure / Canvas reports that the issue has been resolved and Canvas is operational.
Posted Feb 13, 2024 - 14:53 EST
Monitoring
Instructure/Canvas reports that a fix has been implemented and they are monitoring to confirm the issue is resolved.
Posted Feb 13, 2024 - 13:13 EST
Investigating
We are receiving reports that some users are unable to access Canvas. Details available at Vendor's status page. https://status.instructure.com/
Posted Feb 13, 2024 - 12:42 EST
This incident affected: Student and Faculty Services (Canvas).