Network Instability - SE Campus

Incident Report for Eastern Michigan University I.T.

Resolved

This incident is now resolved.
Posted Jul 27, 2026 - 15:06 EDT

Monitoring

The issue has been identified, a fix has been implemented, and we will continue to monitor.
Posted Jul 27, 2026 - 12:38 EDT

Investigating

We are currently investigating a network stability issue in the SW portion of main campus. Buildings affected are Boone, Briggs, Ford, Pease, Pierce, Sherzer, Starkweather, and Welch.
Posted Jul 27, 2026 - 11:52 EDT
This incident affected: Network Services (WiFi Network, Wired Network).