Network instability SW campus

Incident Report for Eastern Michigan University I.T.

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 06:44 EDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Apr 14, 2026 - 16:01 EDT

Identified

We’re currently experiencing unreliable network connectivity affecting several buildings on the southwest side of main campus. The buildings known to be impacted include Boone, Briggs, Ford, Pease, Pierce, Sherzer, Starkweather, and Welch. The underlying cause has been identified, and work is already underway to resolve the issue.
Posted Apr 14, 2026 - 13:45 EDT
This incident affected: Network Services (WiFi Network, Wired Network).