BOE Academic Reports

Incident Report for Eastern Michigan University I.T.

Resolved

BOE academic reports are available again
Posted Jul 29, 2026 - 16:54 EDT

Identified

BOE academic reports are currently unavailable. The issue has been identified and we are working resolve it.
Posted Jul 29, 2026 - 10:27 EDT
This incident affected: Administrative & Enterprise Systems (Banner Reporting).