Starfish
Incident Report for Eastern Michigan University I.T.
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 09:06 EDT
Identified
Some Starfish users have reported intermittent issues with logging in, slow page loads, etc. The issue has been reported to Starfish and they are working to resolve.
Posted Aug 28, 2024 - 11:38 EDT
This incident affected: Student and Faculty Services (Starfish).