Potential Service Disruptions
Incident Report for Eastern Michigan University I.T.
Resolved
We believe we have updated all affected TLS certificates. We will continue to monitor the situation over the next few days to be sure everything is working as expected.
Posted Jul 31, 2024 - 09:12 EDT
Identified
Digicert notified EMU last night that some of our TLS security certificates (the cryptographic keys that are used to encrypt communications between a web browser and a server) must be re-issued because of an error in their process when the original certificates were issued. Digicert will revoke the errant keys at 5:30 today, July 30.

As a result, EMU technical staff will be working today to update all of those TLS certificates on over 130 systems/services. This may result in service disruptions (mostly to web/browser based services) as we complete this work. We currently anticipate any service disruptions to be short/minor.

This is an emergent issue. We are still working/analyzing the situation. We will update here if we anticipate more extensive service disruptions for one or more services.
Posted Jul 30, 2024 - 07:40 EDT
This incident affected: Administrative & Enterprise Systems (Banner ERP, Self Service Banner), Communication & Collaboration Services (EMU Today, www.emich.edu), and Network Services (VPN Access).